Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CWSegmentType Struct Reference

Represents a curtain wall segment element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
short pen
 The pen index.
 
API_CWSegmentCategoryID category
 See API_CWSegmentCategoryID.
 
double gridAngle
 The angle of rows in relation to columns.
 
API_Coord3D begC
 The begining coordinate of the segment.
 
API_Coord3D endC
 The end coordinate of the segment.
 
API_Coord3D gridOrigin
 The origin coordinate of the grid.
 
API_Coord3D arcOrigin
 The origin coordinate of the arc.
 
bool negArc
 The arc of the segment is a negative (clockwise) arc.
 
API_CWSegmentTypeID segmentType
 See API_CWSegmentTypeID.
 
API_Guid owner
 Owner Curtain Wall.
 
API_Vector3D extrusion
 The extrusion of the segment.
 
UInt32 contourNum
 The size of the segment contour.
 
UInt32 patternCellNum
 The amount of cells in the Segment pattern.
 

Detailed Description

Represents a curtain wall segment element.