Archicad 28 C++ API
Loading...
Searching...
No Matches
API_CWallComponent Struct Reference

Describes the simple fills contained in composite structures. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_AttributeIndex buildingMaterial
 The index of the building material attribute.
 
short framePen
 The index of the frame's pen attribute.
 
short flagBits
 The meaning of the flags of the composite wall.
 
double fillThick
 The absolute thickness of the component in meters.
 

Detailed Description

Describes the simple fills contained in composite structures.

Remarks
In Archicad 17 composite skins contain a building material index and skin priority is inside the building material.

Member Data Documentation

◆ flagBits

API_CWallComponent::flagBits

The meaning of the flags of the composite wall.

Value Description
APICWallComp_Core the composite skin is part of the core.
APICWallComp_Finish The composite skin is part of the finish.