Archicad 28 C++ API
Loading...
Searching...
No Matches
API_CalcRulesPrefs Struct Reference

The representation of the Calculation Rules on the Preferences / Calculation Units Rules tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

GS::Array< API_ConditionalElementRuleelementRules
 Conditional calculation rules for elements.
 
GS::HashSet< API_AttributeIndexwallInsulationFills
 Wall insulation fill indices.
 
GS::HashSet< API_AttributeIndexwallAirFills
 Wall air fill indices.
 
GS::HashSet< API_AttributeIndexroofInsulationFills
 Roof insulation fill indices.
 
GS::HashSet< API_AttributeIndexshellInsulationFills
 Shell insulation fill indexes.
 

Detailed Description

The representation of the Calculation Rules on the Preferences / Calculation Units Rules tab page.

Since
Archicad 25
Remarks
The ACAPI_ProjectSetting_GetPreferences function uses this structure to get the settings of the Calculation Rules on the Preferences / Calculation Units Rules preferences page. From API 25 BNZeroMemory, BNClear, or memset should not be used to initialize an object of this structure.