Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ChangeMarkerType Struct Reference

Represents a ChangeMarker (a placeable element, not to be confused with the Change from the Change Manager palette). More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_ChangeMarkerLinkType linkType
 When creating/changing a ChangeMarker or changing the ChangeMarker Default, this field is used to make the ChangeMarker/ChangeMarker Default linked or unlinked. When linkType is APICMLT_CreateNewChange, first a new Change will be created, then the ChangeMarker will be made linked to this Change. When creating/changing a ChangeMarker or changing the ChangeMarker Default if linkType is APICMLT_CreateNewChange, changeId and changeName also has to be supplied, if linkType is APICMLT_Linked, changeId also has to be supplied (changeName won't be used). When querying a placed ChangeMarker, in this field it is returned, whether the ChangeMarker is linked or unlinked. If linked, changeId and changeName shows the linked Change. When querying the ChangeMarker Default, in this field it is returned, whether the Default is linked, unlinked or a new Change will be created when placing a ChangeMarker (APICMLT_CreateNewChange). If linked, changeId and changeName shows the linked Change. If APICMLT_CreateNewChange, changeId and changeName shows what Change will be created when placing a ChangeMarker.
 
API_ChangeMarkerComponentType markerComponent
 This field specifies whether the ChangeMarker has a Marker Head and/or Marker Cloud.
 
GS::uchar_t changeId [API_UniLongNameLen]
 Specifies the Id of the linked Change.
 
GS::uchar_t changeName [API_UniLongNameLen]
 
API_Coord pos
 If the ChangeMarker has no polygon, this coordinate means the reference position, where the ChangeMarker points to.
 
API_Polygon poly
 If the ChangeMarker has polygon, this field contains some data of the polygon (see API_Polygon). The polygon itself can be set/queried through memo.
 
API_Guid markerGuid
 After querying, changing, or creating a ChangeMarker, when the ChangeMarker has a Marker, this field contains the GUID of the associated Marker symbol.
 
double angle
 Marker rotation angle (radian).
 
bool horizontalMarker
 Marker is always horizontal.
 

Detailed Description

Represents a ChangeMarker (a placeable element, not to be confused with the Change from the Change Manager palette).

Remarks
For ChangeMarker related memo data see the ACAPI_Element_GetMemo function.

Member Data Documentation

◆ markerComponent

API_ChangeMarkerType::markerComponent

This field specifies whether the ChangeMarker has a Marker Head and/or Marker Cloud.

Specifies the name of the linked Change.