Archicad 28 C++ API
|
Default settings of 3D document. More...
#include <APIdefs_Environment.h>
Public Attributes | |
API_UniformAttributeOptions | attributeOptions |
General representation of a Model Display. | |
GS::uchar_t | name [API_UniLongNameLen] |
The name of the database. | |
GS::uchar_t | refId [API_UniLongNameLen] |
Reference string / ID of the database. | |
bool | vect3DHatching |
Vectorial 3D hatching option. | |
bool | vectSunShadow |
Vectorial sun shadow generation options. | |
bool | mustBeTransparent |
Transparent effect (see-through Materials e.g. glass). | |
API_CutPlanePlanConn | intPlanConn |
Intended plan connectivity. It could be different from the state of its window. | |
bool | materialFrom3D |
Use Material Defined in 3D Cutting Planes. | |
bool | contureOff |
Vectorial sun shadow contour on(off). | |
API_AttributeIndex | cMater |
Cut surface material. | |
API_SkeletonOptions | skeletonOptions |
Skeleton drawing options. | |
API_BoundaryDisplay | boundaryDisplay |
Boundary display options. | |
short | boundaryPen |
Boundary pen (in case of overridden contours) | |
API_AttributeIndex | boundaryLineType |
Boundary line type (in case of overridden contours) | |
Default settings of 3D document.
ACAPI_View_GetDocumentFrom3DDefaults
and ACAPI_View_ChangeDocumentFrom3DDefaults
functions.