Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ElemPartSurfaceQuantity Struct Reference

Describes the different calculated values for surfaces of elements. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Guid elemGUID
 GUID of the element.
 
API_AttributeIndex materialIndex
 Index of the material, that the surface belongs to.
 
API_AttributeIndex buildMatIdx
 Building material index of the element, that the surface belongs to.
 
double exposedSurface
 Area of exposed surface.
 

Detailed Description

Describes the different calculated values for surfaces of elements.