Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ElemSearchPars Struct Reference

Structure to search for an element by coordinate. More...

#include <APIdefs_Goodies.h>

Public Attributes

API_ElemType type
 element type to search for
 
API_ElemFilterFlags filterBits
 the flags (APIFilt_xxx) used for filtering (see ACAPI_Element_Filter)
 
API_Coord loc
 the location on 2D plan
 
double z
 level to search down from
 

Detailed Description

Structure to search for an element by coordinate.

Since
Archicad 26
Remarks
This structure is used to search for an element by coordinate. Only polygonal elements are accepted and supported. The element type must be polygonal, and passed in the type field. Filters can also be passed to skip instances based on specific attributes, such as visibility, floor number, layer reference etc. Refer to the ACAPI_Element_Filter function for more details. The location to be searched on should be passed in the loc field. The search algorithm will ignore all the elements being on a higher level than specified in the z parameter. The first element will be returned:
  • matches the element type
  • passes the filter
  • the coordinate is an internal point of the polygon
  • has the highest level below z From version 26 the type of the typeID member was changed to API_ElemType.
See also
ACAPI_Element_SearchElementByCoord