Archicad 28 C++ API
Loading...
Searching...
No Matches
API_FillLine Struct Reference

Describes the details of a vectorial fill. More...

#include <APIdefs_Attributes.h>

Public Attributes

double lFreq
 The frequency of a fill line item, i.e. the distance between two 'instances' of this item.
 
double lDir
 The angle of a fill line item, measured CCW from the horizontal axis.
 
double lOffsetLine
 The parallel offset of a fill line item, measured from the (rotated) horizontal axis.
 
API_Coord lOffset
 The offset of a fill line item, given by its coordinates.
 
short lPartNumb
 The number of elements used for this fill line item in the fill_LineLength array. It should always be even.
 
Int32 lPartOffs
 The offset (start) if this fill line item in the fill_LineLength array. It should always be even.
 

Detailed Description

Describes the details of a vectorial fill.

Remarks
Most of the items here correspond to the various parts of the Fill Types dialog in Archicad.