Archicad 28 C++ API
Loading...
Searching...
No Matches
API_GetArcType Struct Reference

Parameters of the arc input operation. More...

#include <APIdefs_Interface.h>

Public Attributes

char prompt [256]
 [in] Prompt string to be displayed in the control box during input
 
bool startCoordGiven
 [in] Use the start coordinate specified in the startCoord field
 
bool negArc
 [out] Negative (clockwise) arc has been entered
 
bool changeCursorSet
 [in] Use the cursorSet field for changing cursor forms
 
bool disableDefaultFeedback
 Disable the default feedback drawing.
 
API_CursorSet cursorSet
 [in] Cursor set for customized visual feedback
 
API_Coord3D origo
 [in] The center coordinate of the arc
 
API_Coord3D startCoord
 [in/out] The start coordinate of the arc
 
API_Coord3D pos
 [out] The end coordinate of the arc
 
API_Neig neig
 [out] The neig found at the end point
 

Detailed Description

Parameters of the arc input operation.

Remarks
For the utilization of API_GetArcType see the ACAPI_UserInput_GetArc function.