Archicad 28 C++ API
Loading...
Searching...
No Matches
API_GetLineType Struct Reference

Parameters of the line input operation. More...

#include <APIdefs_Interface.h>

Public Attributes

char prompt [256]
 [in] Prompt string to be displayed in the control box during input
 
bool changeFilter
 [in] Use the filter field for filtering neigs during input
 
bool changeCursorSet
 [in] Use the cursorSet field for changing cursor forms
 
bool changePlane
 [in] Use the startCoord and planeNormal fields to define the input plane
 
bool disableDefaultFeedback
 Disable the default line drawing feedback.
 
API_NeigFilter filter
 [in] Neig filter for cursor snapping. See ACAPI_UserInput_InitNeigFilter
 
API_CursorSet cursorSet
 [in] Cursor set for customized visual feedback
 
API_Vector3D planeNormal
 [in] The normal vector of the input plane
 
API_Coord3D startCoord
 [in] The start coordinate of the line
 
API_Coord3D pos
 [out] The end coordinate of the line
 
API_Neig neig
 [out] The neig found at the end point
 

Detailed Description

Parameters of the line input operation.

Remarks
For the utilization of API_GetLineType see the ACAPI_UserInput_GetLine function.