Archicad 28 C++ API
Loading...
Searching...
No Matches
API_GetPointType Struct Reference

Parameters of the point input operation. More...

#include <APIdefs_Interface.h>

Public Attributes

char prompt [256]
 [in] Prompt string to be displayed in the control box during input
 
bool changeFilter
 [in] Use the filter field for filtering neigs during input
 
bool changeCursorSet
 [in] Use the cursorSet field for changing cursor forms
 
bool changePlane
 [in] Use the planeCoord and planeNormal fields for defining input plane
 
bool enableQuickSelection
 [in] Enabling Quick Selection (magnetic cursor)
 
API_NeigFilter filter
 [in] Neig filter for cursor snapping. See ACAPI_UserInput_InitNeigFilter
 
API_CursorSet cursorSet
 [in] Cursor set for customized visual feedback
 
API_Coord3D planeCoord
 [in] A point of the input plane
 
API_Vector3D planeNormal
 [in] The normal vector of the input plane
 
API_Coord3D pos
 [out] The coordinate of the clicked point
 
API_Neig neig
 [out] The neig found at the clicked point
 
API_Guid guid
 [out] Guid of the clicked element.
 
Int32 dbElemIdx
 [out] Database elem index of the clicked element.
 
Int32 bodyIdx
 [out] Index of the clicked body in the clicked element.
 
ULong ipgon
 [out] Index of the clicked polygon in the clicked body.
 

Detailed Description

Parameters of the point input operation.

Remarks
For the utilization of API_GetPointType see the ACAPI_UserInput_GetPoint function.