Archicad 28 C++ API
|
Describes a tracing (ghost) database. More...
#include <APIdefs_Environment.h>
Public Attributes | |
API_Coord | offset |
Position of the reference database. | |
double | rotation |
Rotation angle of the reference database. | |
double | scale |
Scale factor of the reference database. | |
GSTime | time |
Last modification time of the reference database. | |
API_DatabaseUnId | parentDatabase |
Identifier of the parent database (i.e. out of which the reference database was created from). | |
API_DatabaseUnId | ghostDatabase |
Own identifier. | |
API_DatabaseTypeID | ghostDBType |
Type of the reference database. | |
API_ShowGhostType | ghostType |
Reference previous/above current/below current story. | |
API_ElemFilter | filter |
Tells which element types are visible. | |
short | floor |
Original floor of the reference database. | |
bool | activated |
Is it activated? | |
bool | show |
Is it shown? | |
API_RGBAColor | ghostColor |
Reference database color with transparency. | |
bool | ghostOriginalColor |
The color of the ghost view. | |
bool | ghostOriginalTone |
The tone of the ghost view. | |
bool | ghostBackgroundFill |
The background fill of the ghost view. | |
API_RGBAColor | viewColor |
Parent database color with transparency. | |
bool | viewOriginalColor |
The color of the originating view. | |
bool | viewOriginalTone |
The tone of the originating view. | |
bool | viewBackgroundFill |
The background fill of the originating view. | |
bool | ghostOnTop |
Is Ghost on the top? | |
Describes a tracing (ghost) database.