Archicad 28 C++ API
|
Describes a hotlink node. More...
#include <APIdefs_Database.h>
Public Member Functions | |
~API_HotlinkNode () | |
Public Attributes | |
API_Guid | guid |
Globally unique Id of the node. | |
API_HotlinkTypeID | type |
Hotlink source reference type (Hotlinked Module or XRef) | |
API_HotlinkStoryRangeID | storyRangeType |
Single or multistory hotlink. | |
GSTime | updateTime |
Time of the hotlink was updated last. | |
IO::Location * | sourceLocation |
Location of the source file. | |
API_StoryType ** | storyInfo |
Story info of the source file. Refer to API_StoryType for further details. | |
GS::uchar_t | name [API_UniLongNameLen] |
Name of the hotlink node. | |
GS::uchar_t | refFloorName [API_UniLongNameLen] |
Name of the hotlinked story. | |
short | refFloorInd |
Index of the hotlinked story in case of single-story hotlinked module. | |
GSType | ownerId |
Owner identifier of the hotlink node (0 means the Hotlink Manager of Archicad) | |
API_HotlinkUserData | userData |
Optional custom data handled by the owner. | |
IO::Location * | serverSourceLocation |
Location of the source file on the server. | |
API_HotlinkSourceTypeID | sourceType |
Source reference type, could be APIHotlink_LocalFile , APIHotlink_TWFS (TeamWork File System), or APIHotlink_TWProject (TeamWork project) | |
UInt64 | fileSize |
Size of the source file. | |
Int64 | versionNumber |
File revision number (only for revisions), Teamwork file system only. | |
Describes a hotlink node.
sourceLocation
, serverSourceLocation
and userData
fields. Make sure those point to memory on heap.
|
inline |
Destroys the hotlink node and cleans up properly.