Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCClassificationReference Struct Reference

IFC classificationreference structure. More...

#include <APIdefs_Properties.h>

Public Attributes

GS::UniString referenceName
 name of the IfcRelAssociatesClassification
 
bool readOnly
 whether the classificationreference is read-only on user interface
 
GS::Optional< GS::UniString > location
 location of the classificationreference
 
GS::Optional< GS::UniString > name
 name of the classificationreference
 
GS::Optional< GS::UniString > identification
 identification of the classificationreference
 
API_IFCClassification referencedSource
 referencedsource of the classificationreference
 

Detailed Description

IFC classificationreference structure.

Remarks
This structure contains the data of an IfcClassificationReference. referenceName is unique for classificationreferences of an element.