Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCPropertyAnyValue Struct Reference

IFC property base value data container. More...

#include <APIdefs_Properties.h>

Public Attributes

API_IFCPropertyValuePrimitiveType primitiveType
 Primitive type.
 
double doubleValue
 Double value.
 
Int64 intValue
 Integer value.
 
bool boolValue
 Boolean value.
 
GS::UniString stringValue
 String value.
 

Detailed Description

IFC property base value data container.

Remarks
This structure contains the base value of an IFC property in one of it's members. The primitiveType field is an output parameter only, shall not be set when setting up a new API_IFCPropertyValue structure.

Member Data Documentation

◆ primitiveType

API_IFCPropertyAnyValue::primitiveType

Primitive type.

API_IFCPropertyValuePrimitiveType Meaning
API_IFCPropertyAnyValueIntegerType Value is stored as an integer
API_IFCPropertyAnyValueRealType Value is stored as a double
API_IFCPropertyAnyValueBooleanType Value is stored as a boolean
API_IFCPropertyAnyValueLogicalType Value is stored as an integer, see API_IFCPropertyValue for possible values
API_IFCPropertyAnyValueStringType Value is stored as a string