Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCPropertyValue Struct Reference

IFC property value data container. More...

#include <APIdefs_Properties.h>

Public Attributes

API_IFCPropertyAnyValue value
 Base value container.
 
GS::UniString valueType
 IFC type of the value in string format.
 

Detailed Description

IFC property value data container.

Remarks
This structure contains the value of an IFC property. The valueType field determines which field of the value structure contains the base value. Each IFC type has a primitive type, e.g. IfcLabel and IfcText both contain a string, IfcReal and IfcPositiveLengthMeasure both contain a real value and so on. IfcLogical type is stored as an integer: | FALSE | 0 | | UNKNOWN | 1 | | TRUE | 2 |