Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCPropertyEnumeratedValue Struct Reference

IFC property with a list of possible and selected value. More...

#include <APIdefs_Properties.h>

Public Attributes

GS::Array< API_IFCPropertyValueenumerationReference
 List of possible values of the property.
 
GS::Array< API_IFCPropertyValueenumerationValues
 List of selected values of the property.
 

Detailed Description

IFC property with a list of possible and selected value.

Remarks
This structure contains the list of  possible and selected values of an IfcPropertyEnumeratedValue. All values shall have the same type. The enumerationReference shall contain all the values of enumerationValues, which shall contain at least one value.