Archicad 27 C++ API
Loading...
Searching...
No Matches
API_InteriorElevationType Struct Reference

An iterior elevation element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 The element header.
 
API_CutPlaneShowType cutPlShow
 Stories to show cutplane on.
 
short storyToShowOn
 Story to show cutplane on, if cutPlShow is APICutPl_ShowOnOneStory.
 
API_SectionSegment segment
 Used to get and set the defaults; real segments are in the memo.
 
bool useCommonMarker
 Show the common marker.
 
API_Guid markerGuid
 Guid of the common marker object.
 
short markerPen
 Pen of the common marker.
 
short markerFont
 Font of the common marker.
 
double markerSize
 Size of the common marker.
 
double markerTextSize
 Size of the common marker's text.
 
UInt32 nSegments
 Number of segments in the memo.
 
Int32 nLineCoords
 Total number of segment line coordinates.
 
API_Polygon poly
 Polyline of the connected segments.
 

Detailed Description

An iterior elevation element.

Remarks
This structure represents an interior elevation element. The section segment information is stored in the element memo.