Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LayerCombType Struct Reference

Layer combination attribute representation. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_Attr_Head head
 Contains the name and the index of the layer combination.
 
Int32 lNumb
 The number of layers in this combination.
 
bool inEffect
 The layers are currently set as in this layer combination.
 

Detailed Description

Layer combination attribute representation.

Remarks
The layer combination attribute contains all the visibility and locking information for each layer. This also means that the number of layers (the lNumb field) has the same value in all layer combinations. When you create a new layer, it will appear in all layer combinations as unlocked and visible. Additional data are assigned to the layer combination attributes in the API_AttributeDef structure; the status information to each layer is passed through the layer_statItems field. Refer to the API_LayerStat structure to get more details on it.