Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AttributeDef Struct Reference

Describes the extended information for different attributes. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_DashItems ** ltype_dashItems
 Contains the data describing dashed lines.
 
API_LineItems ** ltype_lineItems
 Contains the data describing symbol lines.
 
API_FillLine ** fill_lineItems
 Contains vectorial fill details.
 
double ** fill_lineLength
 Contains the lengths of individual parts for vectorial fills. It contains the description of each fill line item in dash-gap length pairs.
 
API_SymbolHatchDef sfill_Items
 Contains symbol fill details.
 
API_CWallComponent ** cwall_compItems
 Describes the simple fills contained in composite structures.
 
GS::HashTable< API_AttributeIndex, API_LayerStat > * layer_statItems
 Describes the visibility and openness of every layer in a layer set.
 
API_AddParType ** zone_addParItems
 Contains the library part parameters of a zone category.
 

Detailed Description

Describes the extended information for different attributes.

Remarks
This structure contains the extended information for certain attribute types. Use the Attribute Manager functions to operate on this data. See also the extension of this structure: API_AttributeDefExt. Use the Attribute Manager functions to operate on this data.