Archicad 28 C++ API
Loading...
Searching...
No Matches
API_SymbolHatchDef Struct Reference

Describes the details of a symbol fill. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_Coord ** sfill_HotSpots
 The coordinates of the hotspots in the symbol fill. The number of hotspots is given in the hotNumb field of the API_FilltypeType structure.
 
API_SFill_Line ** sfill_Lines
 The description of the line items in the symbol fill. The number of line items is given in the linNumb field of the API_FilltypeType structure.
 
API_SFill_Arc ** sfill_Arcs
 The description of the arc items in the symbol fill. The number of arc items is given in the arcNumb field of the API_FilltypeType structure.
 
API_Polygon ** sfill_SolidFills
 The description of all (!) the solid fill items in the symbol fill. The number of solid fill items is given in the filNumb field of the API_FilltypeType structure. The polygons and all the related information is stored sequentially. The following three fields complete the description of the fill polygons.
 
API_Coord ** sfill_FillCoords
 All the vertices of all the solid fill items in the symbol fill.
 
Int32 ** sfill_SubPolys
 All the subpolygons of all the solid fill items in the symbol fill.
 
API_PolyArc ** sfill_PolyArcs
 All the polygon arc segments of all the solid fill items in the symbol fill.
 

Detailed Description

Describes the details of a symbol fill.

Remarks
None.