Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LineItems Struct Reference

Describes the details of a symbol line. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_LtypItemID itemType
 The symbol line item type.
 
double itemCenterOffs
 The vertical distance from the origin of the symbol line. Used in separator, centerdot, and centerline item types.
 
double itemLength
 The length of the item, measured along the length of the item. Used in centerline, rightangle, and parallel item types.
 
API_Coord itemBegPos
 The beginning position of an item. Used in dot, rightangle, parallel, line, circle, and arc item types.
 
API_Coord itemEndPos
 The end position of an item. Used in line item type.
 
double itemRadius
 The radius of an item. Used in circle and arc item types.
 
double itemBegAngle
 The beginning angle of an item, measured from the vertical (!) axis. Used in arc item type.
 
double itemEndAngle
 The end angle of an item, measured from the vertical (!) axis. Used in arc item type.
 

Detailed Description

Describes the details of a symbol line.

Remarks
A detailed example can be found in the APIBases example of the Development Kit.