Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LayerType Struct Reference

Layer attribute representation. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_Attr_Head head
 Specifies the name, index, and flags of the layer attribute.
 
Int32 conClassId
 The connection class of the layer; elements on layers having the same class will be intersected.
 

Detailed Description

Layer attribute representation.

Remarks
Layers work the same way as if you would use Archicad from the user interface. This means you cannot create elements on a locked or hidden layer. This is especially important if you write an I/O type Add-On, as in this case you need to create elements on visible layers, and then modify the visibility of the layers.

There is no additional data assigned to layer attributes in the API_AttributeDef structure.
    The `flags` field of the header can take the following values:
    |Value|Description|
    |--- |--- |
    |APILay_Hidden|The layer is hidden.|
    |APILay_Locked|The layer is locked.|
    |APILay_NotMine|The layer is not mine.|
    |APILay_ForceToWire|The elements on the layer are shown in wireframe mode in the corresponding Layer
    Combination.| |APILay_Xref|The layer is coming from an XREF-ed (DWG or DXF) drawing. These layers are
    grouped in the Layer Settings dialog.|
See also
API_Attr_Head, API_Attribute,
Attribute Management Management