Archicad 28 C++ API
Loading...
Searching...
No Matches
API_NumberingGridLine Struct Reference

Represents a drawing numbering grid line of the layout. More...

#include <APIdefs_Environment.h>

Public Attributes

API_Coord begC
 Coordinate of the starting point.
 
API_Coord endC
 Coordinate of the endpoint.
 
short penInd
 Pen attribute index.
 
API_AttributeIndex ltypeInd
 Line type attribute index.
 

Detailed Description

Represents a drawing numbering grid line of the layout.

Remarks
This structure holds the data of a line of the grid-based drawing numbering system. The stucture is passed as a parameter of the APINumberingGridLineProc callback function while the drawing numbering grid lines are being enumerated by the ACAPI_Drawing_GetNumberingGridLines environment function.