Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Obsolete_ComponentType Struct Reference

Description of a component. More...

#include <APIdefs_ListData.h>

Public Attributes

API_ListData_Head head
 Contains the header information, including type, setIndex and index.
 
char code [API_DBCodeLen]
 Component code.
 
char keycode [API_DBCodeLen]
 Component key code.
 
char name [API_DBNameLen]
 Component name.
 
char unitcode [API_DBCodeLen]
 Component unit code.
 
char dbSetName [API_DBCodeLen]
 Component's database set name.
 
double quantity
 quantity (value) of the component
 
short unitRef
 unit type, see the APIUnitRef_xxx defines.
 

Detailed Description

Description of a component.

Remarks
This structure is obsolete. Use the new component API instead. This structure is used when you want to get the components of an element. These components are in the property objects of the element. See the ACAPI_Element_GetComponents_Obsolete function. This stucture is used when you get or search a component in the listing database. See the ACAPI_OldListing_Get, ACAPI_OldListing_GetLocal and ACAPI_OldListing_Search functions.