Archicad 27 C++ API
Loading...
Searching...
No Matches
API_OpeningCoverFillsParameters Struct Reference

Opening cover fills parameters. More...

#include <APIdefs_Elements.h>

Public Attributes

bool useCoverFills
 Use cover fills.
 
bool useFillsOfCutElements
 Use fills of cut elements.
 
API_AttributeIndex coverFillIndex
 Cover fill index.
 
short coverFillPenIndex
 Cover fill pen index.
 
short coverFillBackgroundPenIndex
 Cover fill background pen index.
 
API_HatchOrientationTypeID coverFillOrientation
 Cover fill orientation (API_HatchGlobal, API_HatchRotated, API_HatchDistorted).
 

Detailed Description

Opening cover fills parameters.