Archicad 27 C++ API
Loading...
Searching...
No Matches
API_OpeningOutlinesParameters Struct Reference

Opening outlines parameters. More...

#include <APIdefs_Elements.h>

Public Attributes

API_OpeningFloorPlanOutlinesStyleTypeID outlinesStyle
 Type of contours on open edges.
 
bool useLineOfCutElements
 Use contours of cut elements.
 
API_AttributeIndex uncutLineIndex
 Uncut line.
 
API_AttributeIndex overheadLineIndex
 Overhead line.
 
short uncutLinePenIndex
 Uncut line pen.
 
short overheadLinePenIndex
 Overhead line pen.
 

Detailed Description

Opening outlines parameters.