Archicad 28 C++ API
Loading...
Searching...
No Matches
API_OperationProfileType Struct Reference

An Energy Evaluation operation profile. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_Attr_Head head
 Contains the name and the index of the attribute.
 
short nDailyProf
 Specifies the total number of Daily Profiles.
 
short nDailyProfUsage
 Specifies the total number of Daily Profile Usages.
 
API_OccupancyTypeID occupancyType
 Specifies the occupancy type.
 
double hotWaterLoad
 Service hot water load per capita.
 
double humanHeatGain
 Human heat gain per capita.
 
double humidity
 Humidity load.
 

Detailed Description

An Energy Evaluation operation profile.

Remarks
There are additional data assigned to operation profile attributes in the API_AttributeDefExt structure; the definition of an operation profile are passed through the op_dailyProfiles and op_dailyProfileUsages fields. Refer to the API_DailyProfile and API_DailyProfileUsage structures to get more details on it. The coverage of an entire year (8760 hours) can be queried by the op_hourlyProfiles structure. Refer to the API_HourlyProfile structure to get more details on it.