Archicad 28 C++ API
|
Specifies what is overridden and how, for an API_Element. More...
#include <APIdefs_Environment.h>
Public Attributes | |
API_OverriddenAttribute | lineType |
Specifies how the line type should be overridden. | |
API_OverriddenPen | lineMarkerTextPen |
Specifies how the line/marker/text pen should be overridden. | |
bool | overrideLinePenThickness |
Specifies if line and pen thickness should be overridden. | |
API_OverriddenAttribute | cutFillType |
Specifies how the cut fills should be overridden. | |
API_OverriddenPen | cutFillFGPen |
Specifies how the cut fill foregrounds should be overridden. | |
API_OverriddenPenOrRGB | cutFillBGPen |
Specifies how the cut fill backgrounds should be overridden. | |
bool | overrideCutFillFGThickness |
Specifies whether the cut fill foreground pen thickness should be overridden. | |
API_OverriddenAttribute | coverFillType |
Specifies how the cover fills should be overridden. | |
API_OverriddenPen | coverFillFGPen |
Specifies how the cover fill foregrounds should be overridden. | |
API_OverriddenPenOrRGB | coverFillBGPen |
Specifies how the cover fill backgrounds should be overridden. | |
bool | overrideCoverFillFGThickness |
Specifies whether the cover fill foreground pen thickness should be overridden. | |
API_OverriddenAttribute | draftFillType |
Specifies how the draft fills should be overridden. | |
API_OverriddenPen | draftFillFGPen |
Specifies how the draft fill foregrounds should be overridden. | |
API_OverriddenPenOrRGB | draftFillBGPen |
Specifies how the draft fill backgrounds should be overridden. | |
bool | overrideDraftFillFGThickness |
Specifies whether the draft fill foreground pen thickness should be overridden. | |
API_OverriddenAttributeOrRGB | cutSurfaceType |
Specifies how the cut surfaces should be overridden. | |
API_OverriddenAttributeOrRGB | uncutSurfaceType |
Specifies how the uncut surfaces should be overridden. | |
bool | showSkinSeparators |
Specifies if the skin separators should be shown. | |
bool | hideCutContours |
Specifies if the contours of the cut surface should be hidden. | |
bool | hideUncutContours |
Specifies if the contours of the uncut surface should be hidden. | |
Specifies what is overridden and how, for an API_Element.
cutFillBGPen
, coverFillBGPen
, draftingFillBGPen
, cutSurfaceType
and uncutSurfaceType
members types are changed to @ref API_OverriddenAttributeOrRGB
. In version 25, the hideCutContours
and hideUncutContours
members were added.