Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PedgType Struct Reference

Representation of a 3D edge reference. More...

#include <APIdefs_3D.h>

Public Attributes

API_3D_Head head
 Header information of this component. This specifies the type and database index.
 
Int32 pedg
 Edge reference. Negative value means opposite direction. Zero value starts a new hole.
 

Detailed Description

Representation of a 3D edge reference.

Remarks
The edges in the 3D model are stored in a list. The value of pedg field is an index to the items of that list. If you go through the edge reference list from fpedg to lpedg, you can obtain the edges of a polygon. (The fpedg and lpedg are available in the API_PgonType record, after you got a polygon of a body by calling ACAPI_ModelAccess_GetComponent function.) The pedg field is an index of an API_EdgeType structure which represents an edge. The orientation of the edge list is counterclockwise (mathematical positive), if you are looking at it from the outside of the body. The orientation of the holes is opposite to that of the parent polygon. If pedg is negative, it means the referred edge direction is reversed. If pedg is zero, it means a contour end; a hole follows.