Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PerspCamPars Struct Reference

Parameters of a perspective camera. More...

#include <APIdefs_Elements.h>

Public Attributes

API_PerspPars persp
 Perspective projection settings of the camera.
 
short waitFrames
 Number of the frames to wait here.
 
short pen
 Pen attribute index for the camera.
 
API_Guid prevCam
 Guid of the previous camera in the same camera set (APINULLGuid if no previous camera).
 
API_Guid nextCam
 Guid of the following camera in the same camera set (APINULLGuid if no following camera).
 
double lenPrev
 Bezier direction length previous.
 
double lenNext
 Bezier direction length next.
 
double dirAng
 Bezier direction angle (radian).
 
bool active
 Active in the path?
 

Detailed Description

Parameters of a perspective camera.