Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PivotPolyEdgeData Struct Reference

Complete polygon descriptor for polyroofs and shells. This structure is used in API_ElementMemo. More...

#include <APIdefs_Elements.h>

Public Attributes

UInt32 pivotEdgeUnId
 Unique identifier of the pivot polygon edge.
 
Int32 filler1
 
API_RoofSegmentDatalevelEdgeData
 Array of API_RoofSegmentData items.
 
Int32 nLevelEdgeData
 Number of items in the levelEdgeData array (indexed from 0).
 
API_ShellBaseSegmentTypeID segmentType
 Arc decomposition method for polyroof pivot edges or revolved shells. (see API_ShellBaseSegmentTypeID).
 
Int32 segmentsByArc
 Cut the arc itself into segmentsByArc straight segments.
 
Int32 segmentsByCircle
 Cut a whole circle to segmentsByCircle segments and use as many as necessary to cover the arc.
 

Detailed Description

Complete polygon descriptor for polyroofs and shells. This structure is used in API_ElementMemo.