Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RoofSegmentData Struct Reference

Describes various properties/parameters of a roof segment that can be separately adjusted. This structure is used in API_PivotPolyEdgeData. More...

#include <APIdefs_Elements.h>

Public Attributes

double angle
 Angle of the plane of the segment to the XY plane.
 
API_LocalCoordsData lcoo
 Texture local coordinates data (see API_LocalCoordsData).
 
API_AttributeIndex topMaterial
 Top material of the roof segment.
 
API_AttributeIndex bottomMaterial
 Bottom material of the roof segment.
 
API_AttributeIndex coverFillType
 Fill of the top surface.
 
double eavesOverhang
 Eaves' extension outside the pivot polygon.
 
API_PolyRoofSegmentAngleTypeID angleType
 The type of Segment. (see API_PolyRoofSegmentAngleTypeID)
 

Detailed Description

Describes various properties/parameters of a roof segment that can be separately adjusted. This structure is used in API_PivotPolyEdgeData.