Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PlaneRoofData Struct Reference

This structure holds the Single-plane Roof specific data of API_RoofType. More...

#include <APIdefs_Elements.h>

Public Attributes

double angle
 Angle of the roof plane.
 
API_Polygon poly
 The polygon of the roof slab, projected onto the horizontal plane.
 
API_Sector baseLine
 Base (pivot) line of the roof.
 
bool posSign
 The sign of the vectorial product of the pivot line vector and the elevation indicator point (its value is 1 if the roof plane raises on the left side of the pivot line vector, otherwise 0).
 

Detailed Description

This structure holds the Single-plane Roof specific data of API_RoofType.

Remarks
For roof related memo data see the ACAPI_Element_GetMemo function. In order to enumerate the planes of the Multi-plane Roof, use the ACAPI_Element_Decompose function.