Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RoofType Struct Reference

Represents a roof element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_RoofClassID roofClass
 Roof class:
 
API_ShellBaseType shellBase
 Parameters common with all shell-based element types.
 
union { 
 
   API_PlaneRoofData   planeRoof 
 Single-plane roof specific data.
 
   API_PolyRoofData   polyRoof 
 Multi-plane roof specific data.
 
u 
 

Detailed Description

Represents a roof element.

Remarks
For roof related memo data see the ACAPI_Element_GetMemo function. In order to enumerate the planes of the Multi-plane Roof, use the ACAPI_Element_Decompose function.

Member Data Documentation

◆ roofClass

API_RoofType::roofClass

Roof class:

API_RoofClassID value Meaning
API_PlaneRoofID Single-plane roof, use the API_PlaneRoofData member of the union
API_PolyRoofID Multi-plane roof, use the API_PolyRoofData member of the union