Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PrimHatchBorder Struct Reference

Hatch border for primitive elements. More...

#include <APIdefs_Elements.h>

Public Attributes

bool doFrame
 The frame of the hatch is visible.
 
API_AttributeIndex fillInd
 Fill attribute index.
 
API_ExtendedPenType fillPen
 (Overridden) pen attribute index for the fill lines. If this value is 1008 (RGB Pen), then the foreground color of the fill is defined in the fillRgb parameter.
 
short fillbkgPen
 Pen attribute index for the fill background. If this value is 1008 (RGB Pen), then the background color of the fill is defined in the fillbkgRgb parameter.
 
short transparency
 Fill transparency.
 
short determination
 Fill category: ||| |— |— | |APIHatch_DraftingFills|Default fill category. Drafting fills adopt the Drafting Fill settings chosen in Display Options.| |APIHatch_CoverFills|The Cover Fill category is assigned to the fills of Slabs, Roofs, Meshes and Zones on the floor plan. Cover fills adopt the Element Cover Fill settings chosen in Display Options.| |APIHatch_CutFills|The Cut Fill category is assigned to the fills of Cut Elements. Cut fills adopt the Cut Fill settings chosen in Display Options.|.
 
API_RGBColor fillRgb
 Foreground color of the fill; valid only if fillPen is RGB Pen (value 1008).
 
API_RGBColor fillbkgRgb
 Background color of the fill; valid only if fillbkgPen is RGB Pen (value 1008).
 
bool isGradient
 The hatch has gradient fill (from foreground to background color).
 
bool isLinear
 The fill gradient is linear, otherwise it is radial.
 
API_HatchOrientation hatchOrientation
 Orientation and distortion parameters of the cover fill.
 

Detailed Description

Hatch border for primitive elements.

Remarks
This structure is used to pass parameters of the hatch to be drawn in the ShapePrimsProc callback function.

Member Data Documentation

◆ determination

API_PrimHatchBorder::determination

Fill category: ||| |— |— | |APIHatch_DraftingFills|Default fill category. Drafting fills adopt the Drafting Fill settings chosen in Display Options.| |APIHatch_CoverFills|The Cover Fill category is assigned to the fills of Slabs, Roofs, Meshes and Zones on the floor plan. Cover fills adopt the Element Cover Fill settings chosen in Display Options.| |APIHatch_CutFills|The Cut Fill category is assigned to the fills of Cut Elements. Cut fills adopt the Cut Fill settings chosen in Display Options.|.