Archicad 28 C++ API
|
A primitive text. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Prim_Head | head |
General primitive element header. | |
short | ind1 |
ind1 in array type parameter | |
short | ind2 |
ind2 in array type parameter | |
short | paramInd |
additive parameter index. Non zero if the text generated by a TEXT2 GDL command with an argument referencing to a text type variable | |
short | font |
Font attribute index. | |
unsigned short | faceBits |
Style of text: | |
short | effectBits |
Special text effects: | APIEffect_StrikeOut | Strikethrough text | | APIEffect_SuperScript | Superscript | | APIEffect_SubScript | Subscript | | APIEffect_Fractional | Fractional text (not used) | | APIEffect_Protected | Protected text (autotext reference) |. | |
API_AnchorID | anchor |
Anchor point of the text. | |
API_JustID | just |
Justification of the text. | |
API_Coord | loc |
Left-baseline position, including the angle. | |
double | heightMM |
Vertical size of text box in mm. | |
double | widthMM |
Horizontal size of text box in mm. | |
double | angle |
Angle of the text [radian]. | |
double | widthFactor |
Text width factor; 1.0 is 100%. | |
double | charSpaceFactor |
Character spacing factor; 1.0 is 100%. | |
A primitive text.
API_PrimText::faceBits |
Style of text:
Face bit | Style |
---|---|
APIFace_Plain | Plain text |
APIFace_Bold | Bold |
APIFace_Italic | Italic |
APIFace_Underline | Underline |