Archicad 28 C++ API
|
Printing parameters. More...
#include <APIdefs_Automate.h>
Public Attributes | |
short | scale |
Printing scale [1..30000]. Ignored if printArea or scaleToPaper is true . | |
bool | grid |
Print also the construction grid lines. | |
bool | fixText |
Print text, arrowheads, and scale-independent dashed lines and fills at the actual size defined in their settings dialogs or proportionally enlarged or reduced to the printing scale. | |
char | printArea |
Print the whole drawing or 3D projection fitting onto a page or print the current zoom or the content of the current marquee area only. | |
bool | printGhost |
Print ghost story as well. | |
bool | scaleToPaper |
Scale output to paper width. | |
bool | newSheet |
Print every zone / page on new sheet. | |
bool | allColorsToBlack |
Print everything in black (Windows only) | |
bool | ditherOnPrinter |
Dither on black-and-white printers (Windows only) | |
bool | usePrinterRes |
Use printer resolution for pictures (Windows only) | |
bool | scaleFitToPage |
Scale output to fit page. | |
API_AnchorID | printAlignment |
Align print area on paper. | |
bool | isStamp |
Is this a stamp? | |
API_PrintStampType | stamp |
The stamp if isStamp is true. | |
double | top |
Top print margin. | |
double | left |
Left print margin. | |
double | bottom |
Bottom print margin. | |
double | right |
Right print margin. | |
Printing parameters.
ACAPI_Rendering_PhotoRender
automation functions. You can retrieve the current printer settings with the ACAPI_ProjectOperation_GetPrinterPars function. API_PrintPars::newSheet |
Print every zone / page on new sheet.
API_PrintPars::printArea |
Print the whole drawing or 3D projection fitting onto a page or print the current zoom or the content of the current marquee area only.
Value | Description |
---|---|
PrintArea_CurrentView | Print current zoom |
PrintArea_EntireDrawing | Print entire drawing |
PrintArea_Marquee | Print current marquee area |