Archicad 28 C++ API
|
Printing header/footer parameters. More...
#include <APIdefs_Automate.h>
Public Attributes | |
bool | addProjectName |
Add project's name to stamp. | |
bool | addProjectPath |
Add project's path to stamp. | |
bool | addViewName |
Add view's name to stamp. | |
bool | addLayerComb |
Add layer combination to stamp. | |
bool | addDispOptComb |
Add display options combination to stamp. | |
bool | addPrintingScale |
Add scale value to stamp. | |
bool | addLoginName |
Add login name to stamp. | |
bool | addDateTime |
Add current date and time to stamp. | |
bool | addPageNumber |
Add page number to stamp. | |
bool | addCustomText |
Add custom text to stamp. | |
char | customText [256] |
User text. | |
API_AnchorID | position |
Position of the stamp. Invalid positions: APIAnc_LM , APIAnc_MM , APIAnc_RM . | |
short | fontID |
Index of the stamp's font. | |
double | fontHeight |
Height of the stamp's font in paper mms. | |
Printing header/footer parameters.