Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PropertyDefaultValue Struct Reference

A structure representing a property default value. More...

#include <APIdefs_Properties.h>

Public Attributes

API_PropertyValue basicValue
 The basic default value when not using an expression. This content of this value is undefined when expression is used.
 
GS::Array< GS::UniString > propertyExpressions
 The list of expression strings in the default value. The content of this array is undefined when basic default value is used.
 
bool hasExpression
 Specifies if the default value holds expression or not.
 

Detailed Description

A structure representing a property default value.