Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RadialDimensionType Struct Reference

Represents a radial dimension. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
short linPen
 Pen attribute index of dimension and witness lines.
 
API_TextPosID textPos
 Dimension text position (see API_TextPosID).
 
API_DirID textWay
 The position of the text relative to the dimension line (see API_DirID). The possible values are: APIDir_Horizontal, APIDir_Vertical, APIDir_Radial.
 
bool showOrigo
 Show arc's origin.
 
bool onlyDimensionText
 Only dimension texts (notes) are visible — no leader line.
 
char prefix [8]
 Place this prefix before the number; example: 'R 7.55'.
 
GS::UniString * prefixUStr
 Optional parameter for accessing the prefix in UniString format.
 
API_MarkerData markerData
 Marker specification (see API_MarkerData).
 
API_NoteType note
 Note parameters (see API_NoteType).
 
API_DimBase base
 Base element for the radial dimension.
 
API_Coord endC
 End of [radial] dimension line.
 
double dimVal
 Radius of dimensioned item.
 

Detailed Description

Represents a radial dimension.