Archicad 28 C++ API
|
Describes a general note, used in dimensioning and hatch text. More...
#include <APIdefs_Elements.h>
Public Attributes | |
short | notePen |
Pen attribute index. | |
short | noteFont |
Font attribute index. | |
API_AttributeIndex | noteLayer |
Layer attribute index. | |
double | noteSize |
The character height in mm. | |
double | noteAngle |
Rotation angle in radian. | |
API_Coord | pos |
Coordinates of left bottom. | |
char | content [64] |
The text or the autotext of the note. | |
GS::UniString * | contentUStr |
Optional parameter for accessing the text or the autotext of the note in UniString format. | |
API_NoteContentType | contentType |
0: measured value 1: custom text | |
bool | fixPos |
Is the position of the note manually fixed? | |
unsigned short | faceBits |
The style of the note: | |
bool | opaque |
The note has background. | |
bool | frame |
The note has frame. | |
short | backgroundPen |
The background color index if opaque. | |
short | framePen |
Frame color index if framed. | |
bool | useLeaderLine |
Whether the note has leader line. | |
bool | anchorAtTextEnd |
Whether the leader line attached to the end of the note text. | |
API_Coord | begC |
Beginning coordinate of the leader line. | |
API_Coord | midC |
Middle coordinate of the leader line. | |
API_Coord | endC |
End coordinate of the leader line. | |
short | leaderPen |
Leader line pen attribute index. | |
API_AttributeIndex | leaderLineType |
Line type attribute index of the leader line. | |
API_LeaderLineShapeID | leaderShape |
Shape of the leader line. | |
API_ArrowData | arrowData |
The arrow type. See API_ArrowData. | |
API_LblAnchorID | anchorPoint |
Anchor point the pointer line is connected to. See API_LblAnchorID. | |
API_JustID | just |
Multiline Text alignment (Left, Center, Right). | |
double | widthFactor |
Width scale of the note's text. | |
double | spacingFactor |
Spacing scale of the note's text. | |
short | rowAnchor |
Text anchor row (First = 0, or Last Row = 1). | |
unsigned short | effectBits |
Special text effects: | |
Describes a general note, used in dimensioning and hatch text.
API_NoteType::effectBits |
Special text effects:
Effect | Style |
---|---|
APIEffect_StrikeOut | Strikethrough text |
APIEffect_SuperScript | Superscript |
APIEffect_SubScript | Subscript |
APIEffect_Protected | Protected text (autotext reference) |
API_NoteType::faceBits |
The style of the note:
Bit | Style |
---|---|
APIFace_Plain | Plain text |
APIFace_Bold | Bold |
APIFace_Italic | Italic |
APIFace_Underline | Underline |