Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RoomImage Struct Reference

Structure for retrieving data related to a room. More...

#include <APIdefs_Environment.h>

Public Attributes

API_Guid roomGuid
 Element identifier of the zone.
 
API_ImageViewID viewType
 Currently not used, only the 2D image (Floor Plan) can be generated.
 
double offset
 Offset of the clip polygon from the edge of the zone.
 
double scale
 Scale of the view (e.g. 0.002 for 1:500).
 
API_RGBColor backgroundColor
 Background color of the generated image.
 
NewDisplay::NativeImage * nativeImagePtr
 Pointer to the output image (must be initialized before calling ACAPI_Element_GetRoomImage).
 
Int32 filler [4]
 

Detailed Description

Structure for retrieving data related to a room.

Remarks
To learn more about the usage of the structure please refer to the ACAPI_Element_GetRoomImage function.