Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ShellShapeData Struct Reference

Contains the profile data of the Shell element. This structure is used in API_ElementMemo. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Coord ** coords
 Coordinate array of the shape polyline.
 
Int32 ** pends
 Polyline endpoints; see API_Polygon for more information.
 
API_PolyArc ** parcs
 Polyline arcs; see API_PolyArc and API_Polygon for more information.
 
UInt32 ** vertexIDs
 Unique identifiers the polyline vertices (unique inside the polyline).
 
UInt32 ** edgeIDs
 Unique identifiers the polyline edges (unique inside the polyline).
 
bool ** bodyFlags
 Flags for each edge. If the edge generates a surface (body when applying thickness) it is true. If the edge serves only to close the polyline, it is false. Normally for open polyline profiles all edge flags should be set to true, for closed polyline profiles only the last edge flag should be set to false.
 

Detailed Description

Contains the profile data of the Shell element. This structure is used in API_ElementMemo.

Remarks
Shell shapes are actually polylines with some additional information. For shell related memo data see the ACAPI_Element_GetMemo function.