Archicad 28 C++ API
Loading...
Searching...
No Matches
API_SingleEnumerationVariant Struct Reference

A container for storing a single value from a list of allowed values. More...

#include <APIdefs_Properties.h>

Public Attributes

API_Variant keyVariant
 The key that refers to a possible enumeration value of the property definition.
 
API_Variant displayVariant
 The display value of the variant.
 
GS::Optional< GS::UniString > nonLocalizedValue
 The non-localized value of the variant, if there is one (e.g. in enumeration built-in properties). This value is useful to handle a specific enum value with the same human-readable value in all localized versions.
 

Detailed Description

A container for storing a single value from a list of allowed values.