Archicad 27 C++ API
Loading...
Searching...
No Matches
API_SkylightType Struct Reference

Represents a skylight element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_OpeningBaseType openingBase
 Common part of windows, doors and skylights (see API_OpeningBaseType).
 
API_Guid owner
 Reference to the container roof or shell.
 
UInt32 vertexID
 For polyroofs it is the ID of the vertex of the pivot polygon. For plane roofs it is always 0.
 
API_SkylightFixModeID fixMode
 Defines how the skylight is constrained in case the angle or the vertical position of the owner roof or shell changes (see API_SkylightFixModeID).
 
API_SkylightAnchorID anchorPoint
 Anchor point of the skylight.
 
API_Coord anchorPosition
 The global XY cooordinate of the anchor point (see fixPoint)
 
double anchorLevel
 The global Z coordinate of the anchor point.
 
double azimuthAngle
 The rotation angle measured clockwise in the horizontal plane.
 
double elevationAngle
 The elevation angle of the roof at the insert position.
 

Detailed Description

Represents a skylight element.

Remarks
For skylight related memo data see the ACAPI_Element_GetMemo function.