Archicad 28 C++ API
Loading...
Searching...
No Matches
API_StairMonolithStructureSymbolData Struct Reference

Represents the data of a monolith Stair's Structure elements. More...

#include <APIdefs_Elements.h>

Public Attributes

API_AttributeIndex goingLineType
 Line type of Stair's Going line.
 
short goingLinePen
 Pen of Stair's Going line.
 
short goingNosingLinePen
 Pen of Stair's Nosing line.
 
API_AttributeIndex goingNosingLineType
 Line type of Stair's Nosing line.
 
API_AttributeIndex connectionLineType
 Line type of Stair's Connection line.
 
short connectionLinePen
 Pen of Stair's Connection line.
 
short connectionDetailLinePen
 Pen of Stair's Connection line on Detail view.
 
API_AttributeIndex connectionDetailLineType
 Line type of Stair's Connection line on Detail view.
 
API_AttributeIndex drainingFillType
 Fill type of Stair's Draining.
 
short drainingFillPen
 Pen of Stair's Draining fill.
 
short drainingFillBackGroundPen
 Background pen of Stair's Draining fill.
 
API_AttributeIndex contourLineType
 Line type of Stair's Contour line.
 
short contourLinePen
 Pen of Stair's Contour line.
 

Detailed Description

Represents the data of a monolith Stair's Structure elements.