Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairStructureDrainingData Struct Reference

Represents the draining of a monolithic Stair Structure element. More...

#include <APIdefs_Elements.h>

Public Attributes

bool enabled
 True, if structure draining is enabled.
 
double width
 Width of the draining.
 
double offset
 Offset from boundary.
 
double horizontalDepth
 Draining vertical depth.
 
double verticalDepth
 Draning horizontal depth.
 
API_OverriddenAttribute material
 Material of the draining.
 
API_StairDrainSurfaceTypeID surfaceType
 Surface type of the draining: |APIST_Stepped|Stepped structure draining.| |APIST_Smooth|Smooth structure draining.|.
 

Detailed Description

Represents the draining of a monolithic Stair Structure element.

Member Data Documentation

◆ surfaceType

API_StairStructureDrainingData::surfaceType

Surface type of the draining: |APIST_Stepped|Stepped structure draining.| |APIST_Smooth|Smooth structure draining.|.