Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairStructureSymbolData Struct Reference

Represents the data of a 2D symbol a Stair's Structure elements. More...

#include <APIdefs_Elements.h>

Public Attributes

API_AttributeIndex visibleLineType
 Type of the visible lines.
 
short visibleLinePen
 Pen of the visible lines.
 
short hiddenLinePen
 Pen of the hidden lines.
 
API_AttributeIndex hiddenLineType
 Type of the hidden lines.
 
API_AttributeIndex visibleFillType
 Type of the visible fills.
 
short visibleFillPen
 Pen of the visible fills.
 
short visibleFillBackgroundPen
 Pen of the visible background fills.
 
API_AttributeIndex hiddenFillType
 Type of the hidden fills.
 
short hiddenFillPen
 Pen of the hidden fills.
 
short hiddenFillBackgroundPen
 Pen of the hidden background fills.
 

Detailed Description

Represents the data of a 2D symbol a Stair's Structure elements.