Archicad 28 C++ API
Loading...
Searching...
No Matches
API_TestSplineFit Struct Reference

Contains parameters to calculate the maximal distance of a spline segment and a set of coordinates. More...

#include <APIdefs_Goodies.h>

Public Attributes

API_Coord ** splCoords
 Fit points of the spline.
 
API_SplineDir ** splDirs
 Direction vectors at the fit points.
 
Int32 nFit
 Number of fit points.
 
Int32 segment
 Segment of the spline to be tested. It can be in the range of [1...nFit-1].
 
API_Coord ** polyCoords
 Coordinates to be tested.
 
Int32 nCoords
 Number of test coordinates.
 

Detailed Description

Contains parameters to calculate the maximal distance of a spline segment and a set of coordinates.

Remarks
Call the ACAPI_ProjectSetting_GetSplineMaxDist function to operate on this data. Refer to the API_ElementMemo structure to get information on the spline parameters. Remember to dispose of splCoords, splDirs, and polyCoords passed if they are not needed anymore.